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INTRODUCTION 

Optimal nesting of materials is the most important task of the procurement production. T-FLEX Nesting 

program is an application for the T-FLEX CAD program and is designed to automate a nesting of sheet 

materials for various types of cutting. The program accurately and quickly calculates the parts nesting 

layout in such a way that the remnants of the material are minimal. Nesting layouts can be exported as a 

T-FLEX CAD drawing and used to prepare programs for CNC machines. For example, they can be used 

when working with the program T‑FLEX CAM 2D, which creates control programs for processing parts in 

two-dimensional geometry. 

 

Example of true-shape nesting layout 

The following types of material nesting exist in the T-FLEX Nesting: 

 linear nesting - nesting of sheets in whips; 

 guillotine nesting allows to obtain optimal nesting layouts of sheet material using through cuts. 

The required parts can be a rectangle shape; 

 true-shape nesting allows to obtain optimal nesting layouts of sheet material. The required parts 

can be of any arbitrary shape. 
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The main criterion for optimization of the received nesting layouts is material utilization ratio, which 

shows the production efficiency. 

Nesting can be used for various types of sheet materials: 

 glass; 

 metal; 

 wood; 

 plastics, etc. 

The main users of the system are the following specialists: 

Normer  - uses the product for normalization of the nesting operations. The main parameter is material 

utilization ratio. 

Technologist  - uses the product to obtain optimal nesting layouts and create a documentation. 

First of all you should create a new nesting project in the program. The nesting project combines the 

initial data, the nesting parameters and the results of the calculation of the optimal nesting. The nesting 

project is created separately for each type of nesting. Set of parameters and geometry differs for each of 

the project types. 

Hatch contours, downloaded from one or more T-FLEX CAD drawings, can be used in the program as 

data for parts and sheets. Moreover, parts and sheets overall dimensions may be set manually in the 

program interface. Number of parts and sheets in the project is not limited. 

Sheets with defects may be set for the guillotine nesting in the program. A defect is a rectangular area of 

a certain size and position on the sheet. The program performs calculation taking into account the 

existing defects. It is possible to set a certain number of parts "to stock" for guillotine nesting to provide 

a stock of the most demanded parts. 

You can setup general settings related to the calculation algorithm (part to sheet distance, part to part 

distance, usable remnants sizes, allow parts inside other parts, solver optimization level, etc.) in the 

project parameters. 

As a result of the calculation the program generates: 

 Layouts of optimal nesting with the ability to display cuts and material remnants, the value 

of the material utilization ratio for each sheet. The resulting nesting layouts can be exported 

to T-FLEX CAD for further analysis and creation of documentation; 

 Summary information about nesting: the number of specified and nested parts and used 

sheets, the values of material utilization ratio and effective material utilization ratio taking 

into account the usable remnants. 

There is associative relation between the contours of parts and sheets in the nesting project and their 

initial geometry in the T-FLEX CAD drawing. Due to this relations, the corresponding contours of parts 

and sheets in the nesting project can be updated when changing the hatching contours in the drawing. 
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The update is done manually, which makes it possible to take into account changes in the original 

geometry, when it is necessary. 

The program allows you to save the nesting project in a separate file to allow subsequent use of the 

nesting project data. 

 

T-FLEX Nesting Functionality 

 

Comparison of T-FLEX Nesting functionality for different types of nesting: 

Functionality  Linear Nesting Guillotine Nesting True-shape Nesting 

Initial data and nesting results 

Nesting of long parts ("in whips")    

Nesting of rectangle sheets    

Nesting of arbitrary shape sheets    
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Manual addition of parts and sheets 

from T-FLEX CAD interface    

Loading parts and sheets from T-

FLEX CAD (manually or from a file) 
   

Using of rectangle and arbitrary 

shape parts 
   

Manual reallocation of parts on the 

nesting layout 
   

Specify part to part distance for 

managing usable remnants 
   

Reports creation    

Export of the nesting layout to T-

FLEX CAD for documentation 

creation 
   

Nesting parameters 

Parts rotation    

Parts inside other parts    

Accounting usable remnants    

Assigning parts to stock    

Accounting sheets defects     

Strategies for parts layout 

on sheets 
   

 

 

TERMS AND ABBREVIATIONS 

Parts. In T-FLEX Nesting system parts are elements that should be placed on the sheets. For some parts 

further processing after nesting may not be required. In this case such parts are semi-finished products. 
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Nesting layout is the result of nesting parts on the sheets in the T-FLEX Nesting. 

Nesting pattern is a technological document created on the basis of the nesting layout exported into T-

FLEX CAD. 

Remains are everything that remains after the separation of parts from the sheet. There are two types of 

remnants: waste (filings, small elements) and usable remnants that can be used in other nesting projects. 

Usable remnant — the term is used for production remnants, which can later be used for the production 

of smaller parts. Dimensions of sheets to be considered as usable remnants are assigned by the user. 

Nesting "to stock" — is used for nesting an additional number of parts to provide a stock of the most 

demanded items. 

Utilization  — material utilization ratio. 
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T-FLEX  NESTING FUNDAMENTALS 

LAUNCHING THE PROGRAM 

Running T-FLEX Nesting is carried out from the T-FLEX CAD program window. The program commands 

are located on the Tools tab in the  Nesting. 

 

Launching the T-FLEX Nesting program 

For the legacy interface, start by using the Tools> Nesting> Project Window command. 

 

PROGRAM WINDOW 

The program window consists of a toolbar and a workspace. 
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The Main menu contains commands for project and results management. 

The File menu allows you to create, open, and save projects. 

 

The Results menu allows you to use the calculation results, in particular, to export nesting layouts to T-

FLEX CAD. 

The menu ? allows you to get help and information about the program. 

The Workspace contains a set of tabs: 

 

 The Parameters tab is intended for setting nesting parameters. 

 The Parts tab is used to manage the list of parts for nesting and their parameters. 

 The Sheets tab is used to manage the list of sheets and their parameters. 

 The Layout tab contains the calculation results: preview of the optimal arrangement of parts on the 

sheet and information on the results of nesting. 
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SAVING OF THE NESTING PROJECT 

Project settings, lists and parameters of parts and sheets, as well as calculation results are saved for a 

specific project and written to a file with the extension * .tfnesting. 

Select File from the main menu. When saving for the first time, select Save As, specify the directory and 

enter the filename, confirm the save. When you use the Save command, changes will be saved to the 

current saved file. 

 

To open the saved file select File > Open. 

If you open another project, the current project will be closed. All unsaved changes will be lost. 

 

NESTING PARAMETERS  

The program allows you to create nesting layouts for different nesting types. To create a new project, 

choose File> New from the document menu and specify the nesting type. The selected type determines 

nesting parameters that are set on the Parameters tab. 

 

The following parameters are available for Linear and Guillotine nesting: 

 

Name. Allows you to specify an arbitrary name for the current project (user comment). 
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Units. Allows you to specify the units used in the project. It allows you to use models that are created in 

different units. The units are taken into account when we import and export data from and to T-FLEX 

CAD. I.e. if the project is in meters in T-FLEX Nesting , then when you transfer data to T-FLEX CAD units 

will be converted to millimeters. 

Nesting Parameters group 

Cutting thickness. Defines the gap between the parts as a result of the cutting. 

 

Part to sheet distance Specifies the value of the minimum allowable distance between the edge of the 

sheet and the contour of the part. 

 

Minimal size of usable remnants sets the smallest size of sheet remnants, which will be considered to be 

usable remnants. 

 

The Sheet Width parameter is available for Linear nesting. It allows you to specify the width for all sheets 

in the project for the proportional display in the preview window. 

The Import Part Hatches from Layer parameter is available for Guillotine nesting. 

It is used to specify the name of the layer, all hatches from which will be imported to T-FLEX Nesting as 

parts. A layer with this name must be created in the T-FLEX CAD document, and all hatches for the 

nesting project should be placed on it. 

The following unique parameters may be set for the True-shape nesting: 
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Nesting Parameters group 

Part to part distance. Specifies the distance between the parts to be cut. 

Part to sheet distance. Specifies the minimum distance of parts from the edges of the sheet. If the sheet 

has a cavity, then this space is also indented. 
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Minimal size of usable remnants. Specifies the minimum size at which the remnant will be considered 

usable. All the remnants are displayed on the nesting layout, and their sizes are displayed when you 

hover the cursor. When changing the parameter value, the layout and information in the reports are 

updated without recalculation. 

Start From. Allows to select the direction for parts layout: Horizontal or Vertical. 

Start From. Allows to select angle from which the layout will start. 

Allow Parts Inside Other Parts. If the parameter is active, it is allowed to place small parts inside large 

parts when nesting. Used to increase the value of material utilization ratio. 
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Nesting layout with placement of small parts inside other parts 

Import Part Hatches from Layer. Allows to specify the name of the layer, all hatches from which will be 

imported to T-FLEX Nesting as parts. A layer with this name must be created in the T-FLEX CAD 

document, and all hatches for the nesting project should be placed on it. 

Import Sheets Hatches from Layer. Allows to specify the name of the layer, all hatches from which will 

be imported to T-FLEX Nesting as sheets. A layer with this name must be created in the T-FLEX CAD 

document, and all hatches for the nesting project should be placed on it. 

Accuracy group  

Solver optimization level. The value can be set from 0 to 100. The higher the value of the parameter, the 

more variants for the estimated placement of the part the program will calculate for achieving the 

optimal nesting, but the slower the calculation will be performed. In most cases, a value from the range 

[5..20] is sufficient. 
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Nesting results at different optimization levels 

Rotation increment Allows you to set the rotation increment. You may allow parts rotation on the Parts 

tab. 
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Nesting results at different steps of the rotation increment 

Permitted increase of part to part distance. The parameter is used for curved contours of the parts, the 

geometry of which can be automatically simplified in the nesting project. The methods for simplifying the 

contours of the parts are as follows: 

No - in this case the most accurate curvilinear geometry of the part is taken into account; 

By Segments or By Arcs - i.e. the original geometry will be replaced by a certain number of segments 

or arcs; 

By Rectangle - with this kind of simplification, the original geometry of the part will be perceived as a 

rectangle which is bounding a part. 

 

Permitted increase of part to part distance parameter allows you to control the degree of 

approximation of the original geometry within the nesting project. For example, at a value of 0 mm, the 

contour of the part shown in the figure will be used without approximation, regardless of the 

simplification type set by user. In this case, the number of contour elements will be maximum and will be 

equal to 150: 
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When the value of the parameter is increased to 7 mm, the contour of the part can be represented in the 

form of eight approximating segments: 
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In fact, the contour of the part shown in the figure, where the value of the parameter 7 mm is the 

maximum deviation of the simplified geometry from the original contour, will participate in the 

calculation. 

 

The spline shows the original contour, the segments are the simplified contour of the part. 

The geometry is always approximated on the outer side of the contour without intersecting the original 

one. The part becomes more simple, and the calculation is faster. The Permitted increase of part to part 

distance affects both the speed of calculation of the calculation and the accuracy of the solution. 

 

 

 

ADDING PARTS 

The program allows you to add parts of rectangle and arbitrary shape. The following ways of adding 

parts the nesting project are possible: 

manually (parts are added one by one in the program interface); 

based on hatches (reading the hatch contours from the T-FLEX CAD drawings); 

 from other projects created in T‑FLEX Nesting; 

 from external tables (multiple addition via the clipboard). 

Supported shapes of parts and ways to set them: 
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Shapes of parts Ways of specifying parts 
Nesting type: 

linear* guillotine true-shape 

Rectangle 

manually    

from external tables    

based on hatches    

Arbitrary shape 
based on hatches    

from product structure    

* the width of the sheet is determined by the width of the part for linear nesting. 

You enter and edit part parameters on the Parts tab of the T‑FLEX Nesting program window. 

 

The use of arbitrary shape parts is allowed in the guillotine nesting. In this case, the overall dimensions of 

the parts are taken into account. 

For correct calculation it is recommended to use parts, the size of which is at least 1% of the 

dimensions of the sheet. 
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Guillotine nesting for arbitrary shape parts 

 

ADD ING  PA RTS  MANUALLY  

Use the   Add Part option to add a new part manually. A new record is added to the 

workspace. 

Use the   Delete Selected Parts option to delete parts from the list. 

Each part has a graphical representation in the right part of the window. 
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ADD ING  PA RTS  F ROM  T-FLEX  CAD  DRAWING S  

You can read the contours of the hatches from the T-FLEX CAD drawing using two methods. 

The described methods are not available for linear nesting. 

1. Selective addition of parts from the active T-FLEX CAD document  

Open the T-FLEX CAD document with the hatches, if you need to add particular contours of parts from 

the drawing. Select the necessary parts (hatches) and in the context menu (or in the Tools tab of the 

T‑FLEX CAD program) select Add parts. As a result, the entries for the added parts will appear in the list 

on the Parts tab of the T‑FLEX Nesting program. 
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Adding parts from the T-FLEX CAD drawing 
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Part in the T-FLEX Nesting window 

In addition, you can add several selected parts or sheets at once using the appropriate commands in the 

Ribbon panel. 

 

After the command activation, you must select all the hatches to add to the project and click . 

2. Adding all the parts from the T-FLEX nesting interface 

Select the  [Import parts] option on the Parts tab to add all parts from the drawing. 

Then select the T-FLEX CAD document, containing the parts for cutting, in the Open dialog window. As a 

result, all the contours of the drawing hatches will be added to the T-FLEX Nesting. 

 

A T-FLEX CAD document can contain a large number of hatches, not all of which are contours for parts. 

In this case, it is convenient to place the hatches for nesting on a special layer, for example, "Nesting". If 

you click the [Import parts] button, only the hatches belonging to this layer will be added to the nesting 

project. The name of the layer is specified in the project in the Import Hatches from Layer parameter. 
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If the hatch in the drawing is changed, it can be updated with the appropriate command from the 

context menu. 

 

 

 

 

ADD ING  PA RTS  F ROM  CRE ATED  PROJECTS  

Select the command on the Parts tab to add all the parts from an existing nesting 

project. You need to specify the document type "T-FLEX Nesting project" in the appeared window. 

 

The parts existing in the current project will not be deleted. Parts imported from another project will be 

added to the end of the list. 

 

ADD ING  PA RTS  F ROM  EX TERNA L  TABLE S  

You can add parts to the Parts tab from external tables.  

First, you need to select the data in the table and copy it. 

 

Then go to the T-FLEX Nesting window on the Parts tab. Then call the context menu by clicking the right 

mouse button in the Nesting window field. Select the Paste command in the context menu. All the 

copied parts will be added to the table. 
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Example of adding multiple parts from the external table 

You can select not only the values, but also the column names in the external table. 

In this case, after insertion in the nesting project, the data is inserted in the appropriate columns and the 

order of the columns is not important. 

 

When inserting from external tables, it is important to consider the conditions described below: 

 When copying only values, the order of their sequence is important. 

 When copying values and column names, the order is not important. 

For each project type, there is a minimum and maximum number of columns copied from the external 

tables. If less data is copied from the table than required in the project, then this data will not be added 

to the project. In other cases, the data is filled depending on the priority of the columns.  

Minimal required data from external tables for different types of projects. 

Project Type Length Width Quantity 

Linear nesting    

Guillotine nesting    

True-shape nesting    

The maximum amount of data is different for each type of project. Boolean value types such as Allow 

Rotation, Allow Mirror, Exclude from Nesting  are not considered when pasting from external tables. 

If the values are copied without headers, it is recommended to copy the minimum or maximum 

number of columns with data for the current project. 

 

ADDING SHEETS 

You can add sheets on the Sheets tab. 
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The blanks have the following parameters, similar to the parts parameters: 

 Description 

 Part No 

 Material 

 Length, Width 

 Quantity 

 Exclude 

Adding sheets is similar to adding parts, except that the sheets can not be added from external tables.  

To add a sheet from the CAD drawing, select Add Sheet in the nesting project in the hatch context menu. 

 

Use the Update button to update the sheet contour that was changed in the drawing. 

For true-shape nesting the use of curvilinear sheets or sheets with cuts is possible.  

An advanced parameter dialog is available for sheets using the Parameters item from the context menu. 

The parameters dialog of a sheet is similar to the part parameters dialog . 
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Advanced sheet parameters 

 

SHEETS  DEFECTS  

It is possible to take into account defects on sheets for guillotine nesting. You can simulate chip, scratch, 

cutout, etc by specifying defect. Defects are specified in the corresponding area on the Sheets tab. The 

defect is a rectangular area occupying a certain position on the sheet. The calculation is carried out 

taking into account this area: 

 Create a sheet and select the   option  (the option   serves to remove defects from the 

list) in the Defects group. 

 Enter the name of the defect (for example "Scratch") in the Name field and specify the area of 

the workpiece in which it is located: 

 X, Y. Specify the position of the defect. The origin of the XY coordinate system is the lower-left 

corner. 

 Width, Height. Specify the size of the rectangular area in which the defect is located. 

The Ignore Defects flag allows to ignore all defects specified for all sheets. 
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Specifying a defect on the sheet 

 

PARAMETERS OF PARTS AND SHEETS 

Parameters of parts and sheets are displayed in the corresponding columns on their tabs. 

Use right-click on any existing part record to call the context menu: 

 

The Parameters item brings up the Part Parameters / Sheet Parameters window, in which an extended 

set of parameters is shown.  

You can select several parts at once and set common parameters for them. To do this, select the details 

holding <Ctrl>. 
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GENERA L  TAB  

The following parameters are available for parts and sheets: 

 

Description. Specifies the name of the part. 

Part No. Specifies the part designation. 

Material The field indicates the material of the part. Details for which the material is specified will be 

placed on sheets with the same material. Utilization ratio is calculated separately for each of the 

materials. 

Length, Width. Specify the overall dimensions of the part. The Width parameter is not specified for 

linear nesting (determined in the project parameters). 
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These parameters in the T-FLEX Nesting interface remain unchanged for parts and sheets 

downloaded from T-FLEX CAD document drawings. Changing the dimensions of the part is made 

in the drawing and can be updated in the part parameters.  

Quantity. Number of parts of this type. 

Exclude part from Nesting. Allows you to ignore the selected parts or sheets in the calculation. 

The following additional parameters are available for the parts: 

To stock. An additional number of parts that need to be nested apart from the number specified in the 

"Quantity" field. Nesting to stock is made on the residual principle when the main parts are placed on 

the sheet, and there is still enough material of the sheet for nesting to stock. To stock parameter can't 

be applied for the true-shape nesting. 

Color. Specifies the color of the part in the nesting layout. 

Allow Mirror. Allows the turning of parts during the calculation of the cutting pattern. 

Allow Rotation. Allows you to specify rotation of part or group of parts in the plane of the sheet.  For 

guillotine nesting - 90 degrees rotation; for linear - the rotation is specified by the Rotation 

increment parameter in the project settings; for the linear cutting the rotation of the parts is not 

provided. 

 

PART  CONTOUR TAB  

A set of Simplify Contour settings is used to simplify the spline geometry of the contours of parts, 

allowing you to speed up the calculation: 

• No - the calculation is made without simplifying the contour. 

• Approximate by Straight Segments - replacement of the contour by linear segments. 

• Approximate by Arcs – replacement of the contour by arcs. 

• Replace by Rectangle - is used in those cases when the shape of a part is rectangular, and 

possible cutouts or bevels should be ignored in calculation. 

The degree of approximation of curvilinear contours of true-shape parts is specified by the Permitted 

increase of part to part distance parameter on the Parameters tab for the true-shape nesting. 

The number of approximating elements is determined automatically and is displayed in the Number of 

contour segments field. 
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Specifying of approximation for the contours of parts is also available in the dialog of parameters of 

polygonal or curvilinear parts, as well as in their context menu: 

 

 File. Contains the path to the T-FLEX CAD drawing from which the shading was loaded. The 

[Browse] button allows you to select a directory for a file with the hatch manually. 

 Hatch ID. Contains the hatch identifier from the T-FLEX CAD drawing. 

 The Update option allows you to take into account the modification of the part contour in the T-

FLEX CAD drawing and transfer the new width and length values to the T-FLEX Nesting project. 

 

There may be a situation where the source contour of the part has been changed. Parts whose contours 

lost relevance will be highlighted in the project window in gray. 
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One of the following actions is required for out-of-date records  (the user himself determines the most 

preferable option):  

- Update using the context menu of the selected record;  

- Delete the part and re-add it to the project. 

If the contours of parts are not updated, changes in the contours of the parts will not be taken into 

account when recalculating the nesting layout. 

You should first save the T-FLEX CAD document to be able to update changed contours. Otherwise, 

links with the source contours can be lost. 

 

PERFORMING THE CALCULATION 

L AYOUT TAB  

Select the  Start Nesting command on the Layout tab to start the calculation. 

 

The calculation with a progress indication starts. You can cancel the calculation with the Cancel button. 
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If there are no parts in the project or there is not a single sheet, the material of which corresponds 

to the material of the part, the calculation will not be started and a corresponding warning will 

appear. 

The results of the calculation are the optimal nesting layouts for the sheets and the summary information 

on the nesting (the number of specified and nested parts, the number of used sheets, the value of 

material utilization ratio). 

Information on the results will be provided in the respective columns after completion of the calculation. 

The results are updated after each calculation. 

Columns displayed in the window may differ depending on the type of nesting. 

 

The window is divided into groups. 

The Materials group displays information about all sheets of the same material. 

Description. Displays the name of the material, if it is specified. 

Parts Nested. Displays the total number of parts and number of nested parts from the specified 

material. 

Sheets Used. Displays the total number of sheets and number of used sheets from the specified 

material. 
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Parts Nested to Stock. Displays the number of parts nested to stock. 

Utilization. The column displays the utilization ratio of the material. 

Utilization Ratio. Displays Utilization with the Minimal size of usable remnants specified for the 

project. 

Parts with the same materials will be placed on the sheets with the same material. 

 

The Sheets list displays information about the sheets.  

Number. Displays the number of the sheet record in the table on the Sheets tab. 

Utilization. Displays the material utilization ratio of the sheet. 

Under the Sheets lists is the Parts list. When selecting a part from the list all the parts of the same type 

are highlighted on the nesting layouts.  

The nested sheets are listed in the order in which they were processed.  

The nesting layout of the selected workpiece is displayed to the right. To view several sheets at once, 

select them by holding down the Shift key. 
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Cutting patterns can be approximated and removed in the preview window by rotating the mouse wheel, 

and moving in the preview window by holding the mouse wheel. 

Using the Show cuts   and Show offcuts  options you can display the cutting lines and sheet 

remnants in the layout for linear and guillotine projects. Options are located in the upper left corner of 

the preview window. 

 
 

True-shape nesting 

The Show remnants  and Split remnants manually  options are available for the true-shape 

nesting. 
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Show remnants displays remnants on the layout. 

  

A remnant can be selected and then deleted using <Del>. 

  

Split remnants manually allows to split remnants on the layout. 

After activation you should specify the first point of the split line. 

  

Next you can create one or several split lines by specifying new points. 
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You can finish the lines creation using double click . In this case, all the remains under the line will be 

separated. 

  

When you recalculate a nesting project, the changes are not saved. Therefore, you should separate 

the remnants only for the final nesting layout. 

Guillotine nesting results 

If the part for guillotine nesting is not rectangular, then the contour is displayed for it. 
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RE AL LOCATION O F  PARTS  FOR  GUI LLOT INE  NEST I NG  

It is possible to manually reallocate the parts on the nesting layout for guillotine nesting. So, for example, 

the user has the opportunity to select a part on the nesting layout and move it to a new location. The 

part can be moved to any of the existing sheets, if there is a remnant sufficient for its placement. You can 

reallocate one or more parts by highlighting them with <Shift>. 

The item is selected at the first click . The second click you need to specify the remnant. 

Manual reallocation of parts on the nesting layout: 
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a) The initial position of the part 
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b) The new position of the part on the sheet 

 

NESTING RESULTS USAGE 

EX PORT  L AYOUT  TO T-FLEX  CAD 

The resulting nesting layout can be exported to T-FLEX CAD for designing nesting drawings. To do this, 

select the  Export layout to T-FLEX CAD command on the Layout tab. Set the 

parameters for export of nesting layout in T‑FLEX CAD in the appeared Parameters of nesting layout 

export dialog: 
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 Group Parts. All parts will be grouped after exporting to T-FLEX CAD. The group should be 

exploded to edit the contour of a part in T-FLEX CAD. 

 Create hatches on the parts. If the option is active, hatches will be created for the parts  in T-

FLEX CAD. 

The hatch step is applied automatically when exported. 

 Use Color of Parts. If the option is active, all parts will  be displayed in T-FLEX CAD in the same 

color as in T-FLEX Nesting. 

 Export Usable Remnants. If the option is active, then usable remnants will be unloaded into the 

document. 

 Create Hatches on Usable Remnants. If the option is active, hatching will be created for the 

unloaded usable remnants. 

 Create Dimensions. Dimensions will be created for all parts and sheets exported to T-FLEX CAD. 

Quantity of parts and utilization ratio will be also displayed on the drawing. If the option is not 

set, then the detail dimension will be displayed in the title block. 

 Place Nesting Layouts on One Page.  It is convenient to use the option for exporting the linear 

nesting layout, where  used sheets in "whips". 

 Show Cuts. Graphic lines that show the location of the cutting lines will be created. The option 

is available only for guillotine nesting projects. 
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 Number Identical Parts. All similar parts in the drawing will be numbered. The option is 

available only for guillotine nesting projects. 

 

 Use template. You can select a document to create a nesting layout in the list: active document 

or a standard prototype of the document. 

The nesting layouts are placed on separate pages in the T-FLEX CAD document. 

 

Nesting layout, exported to T-FLEX CAD 
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PREPA RATION OF  DOCU MENTATION  

If you want to prepare a document using the prototype of document with title block, it is convenient to 

use the copying of the nesting layout with simultaneous scaling. 

 

Copying of nesting layout 
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Inserting a nesting layout onto the pattern 
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Ready Drawing 

If necessary, you can choose the scale of the page for the nesting layout in the dialog ST: Set Document 

Parameters on the Paper tab using the Scale parameter or by using the drop-down list in the View 

panel. 

 

To specify the layout, you can select it and use the Copy with rotation command from the context menu. 
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REPORT  CRE AT ION  

To create a report, you should select Results > Reports. 

 

The Reports dialog appears. 

On the tabs General, Detailed Info and Remains, you can see detailed information about the results of 

the calculation. 
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Click the [Export] button to create a report. The report can be saved in the TXT, XML or XLSX formats. 

Clear result. The option is used when you need to clear result, for example, before sending by mail.  

 

USE  PROTOT YPE  FOR  A  DRAWING  DES IGN  

When using the active T-FLEX CAD document, the parameters of this document will be taken into 

account as a prototype. It means that there will be similar fonts, thickness of lines etc on new pages with 

nesting layouts. Therefore, it is recommended to use similar projects to improve the convenience of 

nesting layouts designing. It is possible, for example, to open in T-FLEX CAD an already designed nesting 

layout with similar dimensions of the sheet as a prototype. The new layout will be generated in a similar 

way, which will save time on designing of the drawing. 

It should be noted that the nesting layouts are always exported to a new page, without affecting 

the already existing drawings. Therefore, the page with the sample design can always be 

deleted. 
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